Can I set up the Wireless iBeacon Receiver to find any BLE device?

Very nice! But I still can’t reach that server:

… so the image and the firmware file is not accessible. :frowning:

Here’s what tells me:

I’ve changed the domain for the file. Please try again.

Great! :slight_smile: The firmware is there, but the image showing the connection is not. Can you change the location for the image too?

(Or perhapst just describe it using text?)

EDIT: No, wait. There it is.
EDIT2: No, it’s not. The U1 connector is not described. Which are RX, TX and Ground?

I changed the domain name again. Please check if it’s ok.

Yes, perfect! :smile:
hank you!

I’m stuck. The AT+SBLUP command returned earlier the same command in green (now it doesn’t any more, perhaps it’s still in image load mode).

However, whatever I do, I only get tons of errors from “SerialBootTool”, whith the final one being “Device Command Response Timeout”.

Please try to restart your computer. You must keep the serial port closed when opening the SerialBootTool.

Yes, SerialBootTool gives a “port unavailable” error message when it’s already open in Termite.

Also: The first step (“power on the device”) refers to the iBeacon Receiver, right?

Restart didn’t help (why should it?). What kind of reply should the AT+SBLUP command give?

I’ve tried both devices I have, the same happens with both.

Have you inputed “AT+SBLUP” in previous steps? The module will not response to any input if you did it. You can skip that step and try SerialBootTool.

OK, that makes sense. The units still work and report their findings like always.

I’ve tried with and without power connected via mini-USB:

  1. if connected to power, SerialBootTool gives error messages as soon as the port is opened or 2) if the power is not connected I get a handshake timeout error.

No new tips og hints on this issue?

Did the device response to any other AT command? Please test with AT+VERS? first

Ok, I’ve given it yet another try!

Here’s what I get:

Steps to replicate, please see if I’m missing something:

  1. Connect the USB UART, it’s on COM3 on my machine
  2. Connect GND to GND, RX to TX, and TX to RX.
  3. Connect a mini-USB cable to the bottom of the device
  4. Start Termite with settings as shown in the picture.

Then no response. I get OK+SCAN from the unit, but it’s like it doesn’t receive commands. Should I press any buttons (I see a “Config” and a "Reset button)?

It seems worked. The data is start with “OK+SCAN:”, end with “\r\n”. The beacon data is in hex format. For Termite, you can choose Plug-ins “Hex View” to observer the data.

the data format:

mac address : 6 bytes
rssi : 1 bytes
UUID : 16 bytes
major : 2 bytes
minor : 2 bytes
measured power : 1 byte

But I don’t get a reply after AT+VERS?
And still no firmware update… :frowning:

There’re so many “OK+SCAN” message. You can stop scan first by the command




After ALOT of trying (and cursing), I’ve concluded that my USB UART device is not sending commands.

I’ve ordered a new one, and will try again.

I’m sad this didn’t work for you. I’m sorry.

I hade the same problem. I had used USB UART 5.0 V device and firmware was able to download.