AB BLE Gateway V4, Msgpack alternative

#1

Hi

I bought a AB BLE gateway to track ibeaons and to hopefully intergrate to my Homey home automation system. On this system i have an MQTT boker and client but my problem is that it apparently cannot raed Msgpack strings. Can something be done to send the messages not as masgpack or use a parser.?

Best regards
Lidvar

#2

Please check msgpack.org. Here’re some exists library for parsing msgpack.

Is this helpful? or do you need a parser tool instead?

#3

Hi,

Thank you for the answer. What I am as you suggest looking for a parser tool. That can parse the code sent from the gateway live, and that my broker can pick up.
Do you know of any out of the box solution for this?
I have a Rpi3 that maybe i can use for this job.
I guess there is no way to change the outgoing message from the Gateway directly?

-Lidvar

#4

We made a tool ble viewer which can subscribe message from MQTT broker and parse message from gateway.

You can also find the source code there. The tool is written in nodejs + electron.

#5

The overwhelming theme I see in these forums are you are a strong advocate for msgPack and everyone else its a giant pain in the a** for them and would like another option. Is there any chance you would consider an optional non-msgpack mode for those of us that would rather not put up w/ that format would just want simple text/json ?

#6

The packet size of JSON is much larger than msgpack (400%). It should be a performance problem.

#7

ok, but in small environments it would still work… I think you should leave this up to the user rather then forcing an opinionated binary codec down everyone’s throat

1 Like
#8

Thanks for your suggestion. We’ll try to add the feature in future.

1 Like
#9

Any idea when ?

#10

New firmware will be available in next week.

#12

hello,

We pushed the beta firmware to OTA server today. Please use our Android config tool to try the firmware

How to upgrade

  • Open the config app and connect the gateway
  • Tap on Advanced
  • Choose beta branch and tap on “update”

Please download the new configure tool for laptop . (Ignore the MQTTS and HTTPS option). This new tool support new option “Request Format”

Let me know if this works for you

#13

The max number of advertising data is 90 for JSON format.

#14

first off let me thank you for turning this around so quickly, I really do appreciate it !!!

Second I noticed the beta client link you sent was windows only… Do you happen to have a build for Linux / OSX ?

#15

I also dont have an android… I did use the old config tool, did yarn start and then ran update firmware… It said it updated but i am not sure if it actually did.

Currently it says its running Firmware Version 1.2.5.17

So how do I proceed given that I dont have a Windows machine or a Android phone ?

#16

@aprilpea So I managed to get a windows machine and run the tool but it doesnt seem to accept / save the JSON option. I have tried restarting it several times and i have even tried simultaneously changing the mqtt topic and the message format and I see the new topic used but w/ the msgPack format…

notice the default topic was ab/hello and the new one was clearly ab/device

#17

Sorry. I forgot to note the firmware version is v1.2.5.21. This version firmware supports JSON format.

The android app can switch to testing branch for gateway. You must do this first. Can you use curl command? I will send private message about how to switch to testing branch by command line.

#18

Thank you , this is great !

#19

Hi, witch android app are you refferring to? i can not seem to find it.

#20

Hi,

How did you switch to testing branch for gateway?
I have same issue as you, by not getteing higher firware thea v.1.2.5.17
@aprilpea is reffering to an android app, but i am not able to find this.

#21

Please check the Gateway Configure Tool v1.0.5 For Android