Sending data from Blueduino central role to another BLE device

I’ve place an order for a HM10 module. Will test it soon

Let me know first the firmware version of HM10, mine is v540 but I could update if necessary, just to try the same

We just got the module today. the firmware version is v545.

Got the chanche to do some testing?

I would be interested about this as well.

hey there, still no news?

Hi all,

We’re a little busy these days. I do some simple test with HM10 module. It seems has a new self learning feature. I downloaded the user manual and read the “HM-10_11 V542 Self-Learning Function Introduction”.

Here’re the command list for HM10 module (firmware V545).

  • HM10 work as central role
  • BlueDuino work as peripheral role
 Those AT Command only need be executed once more
AT+SHOW1 (If you doesnt want to get slave device name, forget this command)
  Now you can use those AT Commands to discovery or connect a slave device.
AT+DISC? (Start a scan procedure)
OK+DISCS (Module response, Start scan procedure)
OK+DIS<P1><P2><P3> (Module response, Found device)
      <P1>: Device Type
      <P2>: Device MAC Address
      <P3>: Device Name
OK+DISCE (Module response, Scan procedure finished)
AT+CO<P1><P2> (Try to connect a slave device)
     <P1>: Device Type
     <P2>: Device MAC address

yes, but the case here is quite different
HM10 works as slave, and blueduino as central, so HM10 is not doing anything

BLE connection works fine, but blueduino is not sending data in UART transparent mode


one more issue: after upgrading to 2.2.3, I am not able anymore to talk to BLE module through arduino HWSerial1. The connection is good, because the sketch is the same as before when I was using 2.1.5, and it works with termite, but it is not working through ArduinoI didn’t notice befpre because it was hooked up with serial-TTL and I was using termite, but now I noticed that after updating to 2.2.3 it does not work anymore!


BLE connection works fine, but blueduino is not sending data in UART transparent mode

HM10 use difference service (0xFFE0) and characteristic (0xFFE1) to send and receive data. BlueDuino use service 0xFFF0 and characteristic 0xFFF1 & 0xFFF2.

one more issue: after upgrading to 2.2.3, I am not able anymore to talk to BLE module through arduino HWSerial1.

You need add \r\n at line end to send AT command. Please try the sketch hardwareSerialMonitor first.

so you’re telling me that there is no way to make the two units communicate?
and why HM10 is able instead to send data through transparent UART to blueduino?

turns out that the 32U4 may be damaged; I reprogrammed it in bootloader mode and now it works. After a few reprogramming, anyway, it hangs again and I have to reprogram it in bootloader mode to unlock the arduino

Hi All!

Im making a blueduino project, the arduino UNO prototype work fine with hm 10 and app for android. Now im adapting the project to blueduino and i have some problems with de communication (i want to work with the blueduino in the same way and protocol with hm10s) to be 100% compatible. I´m learning about reprograming ibeacon with hm10 firm, the chip its the same cc2541but i don’t know exactly the way to do it. im working with arduino and mac.

Im following the topic,i will write if i have any news.
Thanks and comment!!

Hi mickysuarez,

BlueDuino use the chip CC2540 not CC2541. Please note.

April, no news in this regards?

We need add some AT commands to change the UUID same with HM10. We have some on-going projects so will do it after weeks.

Please make this happen fast, I need this in a project that would release as soon as possible.


Hi @teohell @weatherman ,

I did some research today. The HM10 with firmware V545 can also work with service UUID 0xFFF0. So our BlueDuino can play with HM10 module directly.

Please try these commands. I tested and they sent data each other.


The command AT+FFE21 did the trick. It enable two characteristics 0xFFF1 (notify) and 0xFFF2 (write). It’s compatible with our BlueDuino.

thats so simply, really?
I understand these AT commands goes on blueduino. thats correct?
interesting way, i go to try it! :slight_smile:
hanks all!!

Hi mickysuarez,

You should execute these commands at HM10 module not BlueDuino side.