No response from AT command

Hi everyone,

I recently bought a blueduino rev2 and I tried to pair it with my Raspberry Pi 3.
I do find the blueduino in the bluetooth device list of the raspberry but when I try to pair it, it tells me that the authentication has failed:

Pairing failed -
Authentication Failed

In order to solve that problem, I want to change the auth mode. I know that by default it should be no auth and passcode needed but I don’t know what is the problem with the connection to the Raspberry Pi in this case.

Anyway, since I don’t have a USB to UART converter, I modified my Arduino Uno to make transform it into a USB to UART converter.

Here are the connection I made:

I uploaded this code to the Blueduino:

void setup() {}
void draw() {}

I then used Termite (also tried with the arduino IDE) to communicate to the Blueduino:

  • I’m sure I’m using the right COM port since I just have my arduino connected to the computer.
  • I tried all the baud rates.

When I try sending AT, I got no respond at all.

Someone has any idea on what I am doing wrong?

Thank you in advance!

You should change the code to

void setup() {}
void draw() {}

The serial port’s TTL voltage for BlueDuino is 3.3V. It’s 5V for UNO. It also may cause the problem. Please also try to upload the sketch hardwareSerialMonitor to BlueDuino and test it.

I guess that you are refering to the formating since that’s what I wrote in my previous post so I edited it :slight_smile:

I also tried with a voltage divider and it failed as well. I’ll try again and check my calculation for the resistors values.

That’s the first thing I tried and it gave me the error I wrote in my previous post.

Thank you for your time!

Please describe the error you meet. Screenshot for Arduino IDE is welcome

I don’t have an error with the sketch itself. I can upload it in the Blueduino with no problem.
I have a problem when pairing with my Raspberry and I still got the following message, even with the hardwareSerialMonitor uploaded.

Pairing failed -
Authentication Failed

But maybe I did not understand what you meant. Are you suggesting to send AT command with that sketch uploaded onto the board?

You can’t use Raspberry PI to pair with BlueDuino directly. I think you should try bluez. See this topic instead

I tried with my phone also and I got this message:

Pairing refused by ZeroBeacon

You’re using Android phone right? please try the app bluo instead.

Don’t use your phone to connect BLE device directly. use app instead

Quick update in case someone is having the same problem in the future.

Concerning the AT Command:

  • I didn’t find a way to use my arduino uno as a USB to UART converter (even with trying plenty of design)
  • I also trying with my arduino micro with no succes
  • I had to buy a real USB to UART converter in order to make it work. Now AT command work like a charm :slight_smile:

Concerning the pairing:

Thanks for your great sharing!