N03 Beacon - low range

Hi! I am struggling to make N03 beacons to work within some usable range.
Indoors the range varies from 3m to 6m, measured RSSI -100dB, open space.

I am wondering if there’s some known option, or a switch, that I am missing to flip in order to make the beacons to work.

Appreciate any kind of help or input. Poor range is the only thing that’s stopping me from using these beacons. Otherwise no issues!

You can use iOS app AprilBeacon change the TX power to 4dBm. It will get better range.

Hey @aprilpea, thanks for such a quick response! I will try the app, and then will post the result here.

I have been playing with both Android and iOS apps and unfortunately I was not able to access any of my N03s.
However, both apps scan and find the beacons when I visit Tools section of the iOS app, or OTA on Android, but then I can’t take any action.

Are there any other tools I could try using? Thanks!

The iOS app AprilBeacon is the only one option for modifying parameters. Could you please take a screenshot for the iOS AprilBeacon.app when you scan N03 sensor?

Please find the attached images.
Again, thanks for such a quick response!

Please tap the “Bluetooth” at the bottom menu bar. It should find the N03 sensor.

Unfortunately, the list is empty. It scans for a while, but then shows Count:0. Again, on the tools tab I am able to see all active beacons.
I am running the app on iOS 14.5.


@aprilpea I found the issue! All of my beacons have custom names assigned so if you won’t set the name filter in the app settings they won’t appear in the beacons list.

Thanks for the assistance!

Thanks for note this!