Lipo Battery Charger add-on for blueduino not working


I recently bought 2 Blueduinos with 2 Lipo battery charger add-ons. I soldered the Lipo battery charger add-ons to the Blueduinos and plugged in a 3.7V 110mah lipo battery.

I tried to charge the battery (using a 5v, 10W power adapter), but the battery remains less than 3V after more than an hour.

Any advise?


could you please take a photo about how do you wire the lipo charger with blueduino?

Thanks for your reply.

I wired it the same way as the picture on the product page. Here are a couple of pictures:

Is the red led on when you charge the battery? It should be on when charging.

Yes, both the red led and green led are on when I charge the battery. Is the green led suppose to light up only when the LiPo is fully charged?

Maybe it is a problem with the LiPo…

The green led will be on when the battery is full charged. But it’s very strange both LED are on. Do you have any other battery instead?

Hi aprilpea,
Sorry I realised that the problem lies with the LiPo battery which requires special charging (this one:
I tried another LiPo battery and it worked normally.

By the way, I think it will be helpful to put more information on the lipo add-on product page such as:

  • the charge current (600mah)
  • suitable lipo batteries


Thank you very much for your information. Glad to know more