How can I find out the firmware version number?

I’m using the android sdk (
It sees the beacons, when I press “start modify”, it asks for the password. The description of the sdk states that, the default password is “AprilBrother”. I type the password in, but nothing happens, only a notification pops up saying the “… FW should above 2.0”. How can I find out the firmware version?
The “Get Firmware” button doesn’t work either.

which beacon did you use?
AprilBeacon ? abeacon ? ZeroBeacon ? or others

AprilBeaocn sdk can modify AprilBeacon and abeacon.
if you use ZeroBeacon ,you can updata the FM

I’m using this:

you can download the new version ab-sdk-beta1.7.1
this version support asensor

The new sdk does go one step further, but there is still problem.
If I type in “AprilBrother” as password (as written in the description of the github project), it returns with "onPasswordWrong"
If I type in “195660” as password (as the Modifí sets it by default), I get "onErrorOfConnection"
Pressing the “Get Firmware” button still does nothing.

asensor password is 195660
did you use AprilBeaconDemos to set asensor?
did you always get onErrorOfConnection?

I’m using the AprilBeaconDemos, yes.
As you suggested, I’ve tried with an other asensor, and it worked (the first always gave me on onErrorOfConnection).
With the second beacon, even the GetFirmware works.

Thanks for the help!