Help! Serial1 AT COMMANDS


We have just received a batch of 20 blueduino REV 2 boards. Using the “hardware serial monitor” sketch in the AB_BLE library, we can not get the AT COMMANDS to work. I have tried “AT”, "AT+NAME? ", and AT+NAMETETONECM, there is no response. I have tried this on 3 of the 20 boards we received. Suspecting that the new boards came with an updated firmware I tried the new name command “AT+NAME=TETONECM”.

This process works great on blueduino REV 2 boards we received a couple months ago. Does anyone have an idea of what has changed? I pulled the latest version of the library into Arduino but still no luck. What do you do if you can’t communicate with the BLE module?



The firmware for new BlueDuino is v2.2.3. You must append \r\n to the line end to execute at command.

For Arduino serial monitor, you must check the option "Both NL & CR".

1 Like

Thank you!

Good morning, everybody,

I lost a whole day to understand why the AT+NAMEhello didn’t work when it worked well last year with the old devices. Even the AT didn’t give me any information.

I’d seen that different updates had taken place since then on the official wiki but I hadn’t imagined that a line of code could change with an update… Until I stumbled onto the official forum (I didn’t know there was one) and that particular topic.

I followed everything and was getting closer to the solution, finally!

After successfully running AT+VERS? and since I was in 2.2.3, I noticed to change the name, it had changed since version 2.2.1. It is no longer AT+NAMEhello but AT+NAME=hello. Yes, it worked! I change the name Zerobeacon ! Yeah !

An image to celebrate: D

I will be able to concentrate again on my welds: P

Perhaps better warn on the wiki ( that differences in commands may occur depending on the firmware version.

Sorry. It’s a little compatible issue for firmware 2.2 and older version. We’ll add more text at our wiki.

Thank you for your suggestion.

No worries :slight_smile:
Thank you very much for the addition on the Wiki, it’s great!