GatewayConfigTool can't connect

#1

Hi,

I’ve recently purchased AB BLE Gateway V4. and i 'm testing my gateway.
but i can’t find my device on GatewayConfigTool.

my power apater Is it 5V/2A.

Your cable is not powered. So I connected a micro usb for 5V / 2A power supply. I can’t find the device
in configuration ap gatweay v4.

What’s the matter?

#2

Did you wire the network cable to your router? Don’t wire it to your laptop directly.

Your laptop must run in same LAN network with the gateway. So you can use the tool to discover the gateway.

#3

I also having the issue with discovering the gateway. I’ve updated gw to “firmwareVer”: “1.2.5.6” and now config tool does not work for me on android and windows 7 x64.
Do you have maybe description of configuration API or new version of config tool.
Gate way is sending the request, so it works and endpoint show me device information
{
“firmwareVer”: “1.2.5.6”,
“hardwareVer”: “4.0”,
“mac”: “CC:50:E3:85:A1:B4”,
“sn”: 8757684,
“validate”: 1
}
Thank you.

#4

Hi,

The config tool discover gateways by the API you post.

e.g.

  • Let’s say your gateway’s IP is 192.168.1.123
  • config tool request http://192.168.1.123/ , It will show the list if the app request the API successful

Please confirm your android work in same LAN network and you type right LAN IP in the app

#5

HI, yes it is in the same LAN. I’ve tried on different android version but without success. Before update it is worked well.
Thank you.

#6

did you type right IP in the config tool?

  • Let’s say your gateway’s IP is 192.168.1.123
  • You should type 192.168.1.1 in the config tool and tap on “Discover”
  • The config tool start scan 192.168.1.1 ~ 192.168.1.255 for find devices