Firmware Upgrade of Blueduino not working (no handshake)


the Ugrade Procedure as described is not working for my Blueduino Rev2.

  1. I have 2.1.5 Firmware (which is not listed on your Website)
  2. I have a Prolific 0557/2008 USB to Serial Cable. Have Pin 3 on the D-Sub Male identified as TX and Pin 2 as RX as described here:
  3. I connected TX to the TX0 (Arduino Pin 1) as on the layout (the first pin beneath the reset button)
  4. I connected RX to the RXI (Arduino Pin 0) as on the layout (next to the TX)
  5. Connected Ground (D-Sub 9 to GND) as on the layout
  6. I connect with 9600,8,1 No Parity and with CR/LF on Enter
    When I try to connect over the Serial Port (cu.usbserial), the led on the cable lights up. But no answer when I type AT or AT+VER? or similar. I simply do not get Transmission from the board no matter what. Do I have to close a jumper or something to get the Serial to the BLE Board to work?

The Connection works however with the hardwareSerialMonitor, I can sent AT Commands and get a Response.

So do I miss something or do I have the wrong cable? This is a USB to Serial Cable like here:
It has an ATEN UC232A Chip



It’s a RS232 serial converter. You need a TTL serial converter instead. You can search CP2102 at eBay or buy our product ESP Flasher R4.

Hi thanks, I ordered a C2102 UART and it worked. Please add to the wiki how to exit from the Update Status of the Module. I had the Problem that I had to abort after send the AT+SBLUP command because the empty sketch did not load well.
So after that I thought the module was bricked because it did not respond to AT, also not after reboot and reset. So the CC2540 stays in upgrade modus. How can we disable this modus? Luckily I found out because i tried to send the new firmware. Others could think the module was bricked…

Thank you for your mention. I’ve add this to our wiki