Cactus Rev2 cannot access ESP8266

#1

First of all i am pretty new with arduinos. I bought the cactus for a school project.

I have a DHT11 temperature sensor and i tried the example you have on the site. The code was this. CODE

I only changed the sensor input pin and i have all the libraries (dht.h, espuino.h, rest.h) installed.

It compiles without problem, it uploads fine but when i click serial monitor i see nothing.

After some research i found out i need to flash a new firmware so i did this steps.

  1. Uploaded my cactus with esp8266Programmer.ino
  2. Downloaded latest firmware ai-thinker-1.1.1.bin
  3. Downloaded nodemcu-flasher-master
  4. Run nodemcu-flasher-master (i chose x64 version if that matters) and on config i select the file ai-thinker-1.1.1.bin
    and on Advanced i change SPI mode to QIO
  5. It finishes flashing just fine.

So when i try to reupload the project with the sensor again i dont get anything on the serial monitor.

Then i saw something and tried it out this where the steps:

"It will work if you change the baud rate to 9600. Follow the steps:

Get the sketch hardwareSerialMonitor9
Change the line #define BAUD_RATE 9600 to #define BAUD_RATE 115000
Upload the sketch to Cactus Micro
Open the Serial Monitor, you will see some chars can’t read by human.
Just type the AT command “AT+UART=9600,8,1,0,0"
It will not response to any other input now. Restore the hardwareSerialMonitor sketch, change 115000 -> 9600
Re-upload the sketch
It should work now”

After the reupload part i see some cant read letters and i see there that i have a firmware version of 0.9.5.2.
So guessing i didnt upgrade my firmware and i just lost it in the process…

I wrote it as detailed as i can so sorry for the long read.

#2

Hi,

I checked the code. It’s depend on the espduino firmware. But you uploaded the AT firmware to the board. So you should re-upload the espduino firmware.

You can found the espduino firmware here.

Note: The espduino firmware doesn’t support AT command. You don’t need learn about AT command any more.

You can write a simple sketch to test if the serial works. For example:

void setup() {
  Serial.begin(19200);
}

void loop() {
  Serial.println("loop");
  // Add read sensor code and print it here 
  delay(1000);
}
#3

Thank you very much for your help and time. I had to flash both firmware : 0x00000.bin and 0x40000.bin
at the same time for it to work.