Cactus Micro no longer detected (Windows 8.1)


I have been working with a Cactus Micro for several weeks, but now suddenly it’s no longer detected.

I use Windows 8.1, and the Cactus Micro appeared in the Device Manager as an Arduino LilyPad USB. But last night, while I was working with it it just disappeared from the Device Manager. I did not update anything, I was just working with it (uploading different sketches).

I have tried in several Windows, and it does not appear in the Device Manager. Sometimes it appears for some seconds as “Arduino LilyPad USB BootLoader”, and then disappears again. I have tried with, and without the wifi board plugged.

Any clue?

Thanks for your time.

To revive the Cactus Micro, you’ll need to find a way to upload a sketch to it with the board option correctly set. We can do this with a little help from the bootloader.

First, you’ll need to set the serial port to the bootloader. But that port is only visible when the board is in bootloader mode, so pull the reset line low twice quickly to invoke the bootloader reset feature discussed above. You can quickly press the reset button twice. While the Cactus Micro is in the bootloader change the ‘Tools > Serial Port’ menu to the bootloader COM port. Quick! You’ve only got eight seconds. On Windows, the bootloader’s COM port number is usually one number higher than the Cactus Micro’s regular port number.


It worked!

I had to give it some tries. But I got to get it working again.


Info for others with the same problem:
You have to be really quick, eight seconds to detect the com port, and to compile and upload a sketch, it’s a bit sort. You have to do it in several tries, one to detect the com port, and other to upload a sketch. Any sketch is fine, the shortest the better.

I think it’s a common issue for ATMega32u4 based arduino. It will be bricked if you have chosen wrong board.

I just tried it again with windows 8.1 on my macbook,

That part worked, after a few tries I uploaded a sketch but then it still disappears…
So it didn’t worked for me


Try uploading a very simple sketch, like the blink sketch that comes with the Arduino IDE.

I bricked my Cactus Micro with a faulty sketch, so uploading the faulty sketch worked (it uploaded) but bricked it again.

Could you please send the “faulty” sketch to me? I’d like to have a try.


I have uploaded the code to

Open the “wheatherStation2.ino” file. I think the faulty line is the line number 59 (commented).

I was playing with power states. I don’t know if the Cactus Micro support these power states.

Maybe it’s not really a faulty line…

If you study the code, you will see that I keep the board powered on just for a couple of seconds, which is not enough to detect it anymore.

Just playing with code!!! :smile: