BlueDuino Rev 2 not appearing in BlueDuino app, Bluo or any other BLE scanning app

Hi Guys,

I have a rev 2 of the blueduino and scanning it on any app and the ZeroBeacon is not coming up. The funny thing is, it came up in the Blueduino app a week ago, have not touched the board since and tried today to do some programming and it decided to hide itself.

I’ve uploaded the ABControl sketch and uploaded to the board, any code to light an LED from the output pins works, just no bluetooth.

Is there a fix for this?


Did it work with AT command? Please try these steps:

  • Upload sketch hardwareSerialMonitor
  • Test at command “AT”, you will see “OK”
  • Test at command “AT+VERS?”, you will see the firmware version
  • Test at command “AT+ROLE?”, you will see the BLE role. you can only scan the module when it work as peripheral role (OK+ROLE:1).

Thanks for the quick reply pea,

Typing those commands into the serial monitor yield no response from the board.

If your phone connected bluetooth automatic, the blueduino can’t also accept any at command. You can’t also scan it by app.

Turn off bluetooth of your phone first and try at command again?

The two devices it previously connected to have their bluetooth off and tried the AT command again, the command still returns no data.

The hardwareSerial.ino sketch is printing the “Hello BlueDuino!” fine.

Did you mean there’re two BlueDuinos and they can’t be scanned both?

Sorry for the confusion,
I could previously connect to the board on my iphone and my imac. I’ve switched the bluetooth off on those to try sending AT commands.

Did you add “\r\n” at the end of the at command? There’s no response if no newline flag.

Do you have a USB to UART converter 3.3V TTL? Please try to send AT command to BLE module directly if you have one.

  • Wire the USB to UART converter and BlueDuino
  • Converter GND to BlueDuino GND
  • Converter RX to BlueDuino RXI (Serial1)
  • Converter TX to BlueDuino TXO (Serial1)
  • Plug the BlueDuino to PC
  • Wire USB to UART converter to PC
  • Open a serial terminal software and change baud rate to 9600
  • Send at command “AT”. Don’t forget add “\r\n” at line end

I tried the \r\n with and without the commands to no avail.

I will try to source a USB to UART converter 3.3V TTL and let you know the results!

Note: for arduino IDE, just check the option “Both NL & CR” for appending “\r\n”

I used those options without \r\n, and No Line Ending with \r\n and nothing came up. I’m going to try the USB to UART method and see what comes up!

Hi again,

Tried talking to the BLE module directly with the USB to UART and no response came back. I was testing this board for a class next semester. We were hoping to purchase another 25 but the fragility of the module worries me. Is there any distributor in Europe or UK that distributes the blueduino?


We’re sorry for the module stop working. We can send an additional BlueDuino to you if you place next order.

Notice: It’s a static-sensitive devices. I can’t say what cause the problem.

We were hoping to purchase another 25 but the fragility of the module worries me. Is there any distributor in Europe or UK that distributes the blueduino?

Sorry. No distributor in Europe or UK yet. You can place order at Tindie directly and leave a message to us.

Hi I have the same problem.

I just received my BlueDuino Rev 2 and Powered it with the USB cable.
But it does not Appear on Bluetooth scan on my IPad mini or my phone Xiaomi Redmi HM 2LTE-CU.

I uploaded the hardwareSerialMonitor sketch. And here are the answer of the AT command

Could you please help me?

Your board should works good because AT command is ok. Did you change the ROLE?

I checked the MAC address:
AT+ADDR? I got OK+LADD:0x000000000000
Is this normal?

It may work at central role. Please change it first. Run these commands


I entered


and Ok now I can see it.
Thanks for your help.