BlueDuino R2 - programmer is not responding after AT+SBLUP


I updated some BlueDuino R2 to 2.2.6 successfully, but on some boards I can’t upload an empty sketch after “AT+SBLUP” command.

I tried the process described “How to Revive a “Bricked” BlueDuino Rev2”, but I push the reset button twice and it don’t show a new COM.

Could you please help here?

Thanks in advance,

This way is only effect after you chosen a wrong board type.

Please double check the com port. I think you can also upgrade the Arduino IDE to latest version.

The COM is correct, I receive the “hello” from your default sketch, but AT no answer as expected because it is in update mode.

Even with the last Arduino IDE (1.8.3) same error:

Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding

It looks like the COM port is not available after Arduino IDE reboot it to upload the sketch, but it is ok when you plug it for the first time.

There is a way to avoid/block the reboot from Arduino IDE? And try to update just when connect the USB for the first time?

Good news here, I uploaded the empty sketch, using a Mac!

I don’t have idea why, but it worked and allowed me to update the firmware and continue my project.

I will be happy if you can help me in make this work on Windows too, but I’m not stuck anymore.


It’s very strange. Is the windows 10 or 7?

Windows 7 (64 bits)

does your laptop support USB 2.0? BlueDuino can’t work with USB 3.0 well.

Yes, as I said some boards was updated correctly and some boards not.
That’s the most strange for me.