Blueduino Firmware Update (AT commands not working)

Hello, I want to update firmware for my blueduino.
As shown on the wiki, I connected the Blueduino to the usb to serial converter with RX, TX, and GND and proceeded with the serial communication by using Termite 3.4. But I can’t receive OK message when I send AT . (I send message by using Termite.)
On the other hand, When I connect to BLE by using Bluo, OK + CONN appears. (See image below)

I’ve run all 8 devices I own, but it’s not all up. (I do not know if I made the wrong setting.)
Here is my termite setting. (COM9 port is serial converter tool)

The program I uploaded to Blueduino is the hardware serial monitor, BLE chat in the library. I also tried it in a blank situation.

And I tried the firmware process using the serial boot tool, but I can not proceed with the handshaking error.

Please confirm and reply. Thanks in advance!

For AT command, you should check the option “Append CR-LF” for termite. Is this the problem?

The AT command does not apply even after applying “Append CR-LF”

You should disconnect all BlueDuino from Bluo. AT command can’t work if BLE module is connected.

I disconnected all but it doesn’t work.

I believe the Terminal connection through the UART is 115200?

I set 9600. But when I set 115200, it doesn’t work too.

I have two questions

  1. Which upgrade steps have you done? Please check steps at the wiki first.
  2. Can it response to your bluo app now? If yes, the blueduino does not go to upgrading mode. It should response to your AT command.

Could you please also take a photo for how you wired the USB to UART converter and BlueDuino?

  1. I just finished connect the devices.
  2. Yes, my device responses bluo app.
    And here’s my photograph wiring the BlueDuino and USB to UART converter.%EC%88%98%EC%A0%95%EB%90%A8_KakaoTalk_20180730_114303608%EC%88%98%EC%A0%95%EB%90%A8_KakaoTalk_20180730_114305970%EC%88%98%EC%A0%95%EB%90%A8_KakaoTalk_20180730_114304966

So the COM9 is the com port for the USB to UART converter, not for BlueDuino right?

Please try these steps also:

  1. Write an empty sketch to BlueDuino.
void setup() {}
void loop() {}
  1. write at command to USB to UART converter directly.

Yes. COM9 is com port USB to UART converter. BlueDuino is COM10/


And I follow your steps, It finally works!
I do not know what was the problem, but I captured the terminal settings for those who have problems like me.


Thanks a lot!

You may programmed other sketch to BlueDuino. The serial code from the sketch will block your AT command to UART converter.