AT command not response from my Blueduino by using HardwareSerialMonitor

AS topic my BlueDuino can not response any AT command, even I turned off all my Bluetooth devices. Does it means there is something wrong with the Bluetooth module inside the blueduino? because I can only see “Hello BlueDuino” on Serial monitor! Could you please help me to identify the problem?
Many thanks!

That’s strange. You setting for serial port is correct. Could you please test it at another laptop?

Yes, I did the same test on XP and Win 10 laptop. both are same result !

Could you please take a photo for the device?

Please kindly take a look!

Do you play the device first time? If yes, please send me a private message about the order ID and where you bought the device. We can send a replacement device to you.

Did you do any other work like “update firmware for the BLE module”? If yes, please complete the update progress first.

I play Arduino related stuff for a long time and I didn’t do any firmware update on this!
This device was bought from an online auction dealer in Taiwan. the dealer advice to send my problem to you and expect your judgement if it need to be replace another one!

I don’t know how to send the message of the dealer to you, I only have the email : MCU Technologies .
Thank You for help!

I’ve sent a private message to you. Please check it.

Many thanks for the effort!

Have a some problem

Early in trying to get the serial monitor to show information, I’d either get nothing or unprinted characters (the Square-looking character) on the monitor.

The only way it worked for me is to connect up as in attempting to update the firmware on the CC254x, but issue a baud rate change to the chipset through the Termite terminal program (AT+BAUD0) 9600 baud and then I was able to see things in the terminal. With that, you should just buy a USB to TTL converter, cheap but priceless when you need one.


Hi @fchiang,

I have exactly the same problem.
Did you find a way to solve it?