Quirky AT+SDUR behavior


#1

Here’s something interesting I discovered yesterday:

When BlueDuino is in Central Role, if you set scan duration to 10 seconds, and then scan for a beacon that is advertising once per second…

You would expect to get 10 scan results BUT in fact, you only get one result. This is because (I think) the CC2540 has a built-in function that prevents repeat results. This can possibly be turned off via the firmware of the CC2540, but I don’t think we have access to that.

I am using version 2.1.5 of BlueDuino, so maybe this has changed in the newer versions. I would assume not.

Just thought it would be interesting to share this observation. I learned the hard way by setting the scan duration to 99 seconds and then going crazy trying to figure out why I was only getting one scan every 99 seconds when my goal was to get as many scans as possible. Me dumb.


#2

Yes. The TI’s ble-stack prevents repeat results. It also work (a little weak) even you turned off “unique results”. For get more scan results, I suggest you set a little scan duration. for example: 100ms.


#3

Yes, I am going to lower the scan duration to lower than 1000ms and see if that helps. Only problem is that my testing platform is using one of your older BlueDuinos with version 2.1.5. (which can’t be set to duration lower than 1000ms). I’m too lazy and unskilled to upgrade the firmware. :slight_smile:

The good news is that I already have another backup BlueDuino that I purchased more recently, so I assume that will have the newer firmware on it.

Now I just have to find some way to trick somebody into soldering the pins for me… :wink: