Setting DA14580 password using AprilBeacon App


I don’t know if I just fail miserably. But I can’t simply figure out how to set the password for EddyStone URL’s. There’s password option in iBeacon mode yes. But if I enter new password there nothing happens. What’s the password format? I assume it’s 12 characters. I’ve tried 6 digits, 12 digits, 6 characters, 12 characters and nothing seems to work. Also the AprilBeacon App seems to crash really often and it’s actually pretty bad.

So everything was really trivial except setting a password which prevents changing the url by other users.

  • Thank you

All physical stuff, like the beacon bracelet, key chain enclosing etc, are really nice. Only thing which I’m not happy about is the app and this very simple issue. I’ve been now playing about 1.5 hours trying to set the password and nope. I haven’t figured out how to do it.

It would be also nice to know the default password in the App. Because once I changed the app password and only way to get the unknown default password was to reset the whole app.

Best regards,
Sami Lehtinen

The default password for DA14580 is 195660. Did you upgrade app AprilBeacon to newest version?

The passcode is 6 characters.

I’m using the latest app from Google Play naturally. If there’s firmware update, no I didn’t do it. I just tried change the password. New password is required to be 12 characters long. Which is good. Yet the password change failed miserably and the application crashed.

Any pro-tips? This should be really trivial, but now it’s more like frustrating.

I would like to add that the power information seems to be misleading too. Apps show that the transmission power would be -100dBm. And therefore apps report beacons being very close even if those are further away. Even when configuring the beacons I’ve used 0 dBm power level.

It also seems that the configuration app doesnt handle all (?) suffix and prefix options.

Yes modify new password is the bug of the app ,we will fix it today.

The bug is fixed, keep wifi open and open app again to update the version of 2.3.2

Thanks, got it. I’ll be reporting back bit later.

– Ok results –

Now the password set doesn’t error immediately. But the settings password still requires 12 chars and the password change still fails. It says modified successfully but the default password keeps working and my own password won’t. So something is pretty badly implemented here. Please fix the app properly. - Thank you - I just hope that the hardware isn’t broken so that the password can’t be changed. Hopefully it’s just the app which sets it which is still broken.

I guess these devices don’t have OTA firmware upgrades?

– Some later thoughts –

After thinking a while, I gues the -100dBm is intentional. It makes the EddyStone-URL mode to misreport distance, and makes beacons seem to be really close when receiving signal at all. Kind of trick to get those at top of list when sorting based on distance. Kind of scam & spam / click jacking, but it works. Ha.