Cactus r2 Not displaying in COM

So I got the r2 of the cactus micro 8266. I uploaded a blink sketch and it successfully uploaded, although the light onboard is always a solid red, so not sure if it was working. I then uploaded a sketch for another analog input. However, it did not successfully upload.

Now as it failed, the board disappeared. I had not chosen the wrong board type, so I am not sure why this happened. More concerning, I have tried quickly double pressing the reset button, but the Serial port does not show up as described (this is on mac osx and arduino ide 1.6)

Basically the sketch is for a gyro sensor, which I would in the end like to wirelessly communicate the data from that sensor using the cactus.

Does anyone have ideas of what happened?


Please try the Arduino IDE 1.0.6 again.

Could you please show me the sketch?

It seems switching to 1.0.6 allows code to be uploaded, thanks.

However, the code I need to use is

It is used on 1.6, and is the code that made the micro cactus disappear. Is there a way to get it working with 1.6?

The sketch define the pin 13 as LED_PIN. I think it’s a problem. Cactus Micro R2 wires pin 13 to ESP8266 CH_PD pin.

Please refer the wiki for more information.

Do you know who can help?
I have the same problem but with example sketch from library: “cactus-micro-r2\libraries\CactusMicro\examples\searchBaudRate\searchBaudRate.ino”.

  • Which board did you choose?
  • Can you replace a micro usb line?

I’ve chosen “Cactus Micro Rev2 tiny size”

What do you mean “replace a micro usb line”?

Open Arduino IDE and choose board “LilyPad USB”. Did you choose the right board type for Arduino IDE?

We have some user report the can’t found the com port because the micro usb cable has problem.

I have already “LilyPad USB”.
In general I have two board and problem with one only - the same environment (second one I don’t want to lost too).

Please try the link How to Revive a “Bricked” Cactus Micro"

In this way I can upload a new sketch (I have only several seconds for it while proper serial port is shown) but serial port disappears again.

Which version Arduino IDE did you use? Please try with Arduino 1.0.6. It’s more stable for Cactus Micro.

I don’t want to use such historical version. :-/
Actually I use 1.6.5 and I think it is very stable for me.
Why do you prefer 1.0.6 and how can you proof that it is more stable than 1.6.5?
Besides I prefer Atmel Studio IDE - much better and with IntelliSense.

We have some users report can’t work with 1.6.x. Please see here, here and here. I think you can install multi version Arduino IDE.

Please have a try.

But I have two Cactus R2 from you and one of them works fine.

It works now :slight_smile:
My solution: in Device Manager I’ve removed (uninstall) device “Arduino LilyPad USB” and then new driver has been installed again automatically.

Great! But it’s very strange.