Failed to configure sniffer request interval to 1 second


#1

Hi,

Recently I used my javascript paho client to receive messages from emqttd via websocket protocol.

However, I noticed that beacon messages arrive every 10 seconds instead of 1 second. I have tried to configure the request interval to 1 second and restart the sniffers using my WiFi-starter app, but it didn’t work.

Any advice on this issue?

Thanks in advance.


#2

One more thing: the system configuration section under setup page doesn’t actually show the real settings of the sniffers.


#3

Did you change the setting with Safari? Please use chrome instead. It’s a know issue for compatible with safari.

Let me know if this work


#4

Somehow I accidentally configured a sniffer successfully once, but I’m not sure what’s the correct way of configuring this. Correct me if I’m wrong, the exact steps are:

  1. Open url in chrome browser (mine is chrome app on iphone)
  2. Enter setup page
  3. Select request interval to 1 second in"system" section
  4. Click submit button in this section
  5. Click “restart device” at the bottom
  6. Power off sniffer and wait a few minutes
  7. Power on sniffer and check parameters

#5

Do all three modes (Full mode, simple mode and RAW mode) support request interval from 1s to 10s?


#6

Your steps are right. All modes support request interval from 1s to 10s.


#7

Thanks. now I realised the problem solution: to actually set the request interval to 1s, I need to go to the system section of setup page, select 2s or any other options and then select 1s option back.

It seems that if I just submit the default option (1s) without changing it back and forth, it won’t work.

The same goes for mode selection.

Thank you very much for your help.