Blueduino固件升级不成功


#1

我最近尝试对blueduino rev2进行固件升级,但多次尝试仍然失败,并且之后ble没法接受AT 指令。请问有可行的办法重新设置,至少让ble能够接受AT指令?
谢谢。


#2

请问你是否已经发送了 ```AT+SBLUP`` `指令进行升级?可否拍照看看你的串口接线方式?

if如果已经进入了升级状态,只有升级成功才可以恢复AT指令模式


#3

是的,已经发送了AT+SBLUP, 而且返回了OK+SBLUP
之后usb/uart 一端连接电脑,一端连接bleuduino, uart RX对RX1, urartTX对TX0,GND到GND
然后开了TI的serialboottool, 选择BLE, 152000 baud, open com口,最后有个错误信息如下
显示“device command response timeout handshake“

谢谢


#4

可否把这些选项的界面也截图看看?另外检查串口的COM号是否和设备管理里面找到的端口号一致


#5

端口是一致的。


#6


#7

请尝试烧写一个空的sketch到BlueDuino,然后再次尝试升级,例如

void setup() {}
void loop() {}

#8

还是不工作:disappointed_relieved:


#9

请问在哪里购买的?可以联系我们的淘宝客服,寄回来升级一下


#10

在海外买的,寄回去估计比较困难。
ble那边没有重新设置的功能么?
如果不行,我准备直接从你们官方网站再买一个。请问能保证买到最新firmware的blueduino么?


#11

没有重新设置功能。可否给blueduino来一张正面照片?确认一下是不是rev2

如果你在官网购买,把订单号私信发给我。我会嘱咐客服先升级到新版本


#12


#13

谢谢你。


#14

如何私信,发到哪个邮箱或者地址?:slight_smile:


#15

私信是指在这个论坛里,点我的名称,然后选"Message"发送消息。已经看到你的订单,会升级成2.1.7固件发给你


#16

谢谢。另外,请问ESP Flasher R4将来可以用来升级blueduino的固件对么? 你们推荐的是ESP8266 Flasher Rev2,但是好像已经停产了? r4是rev2的升级版本?


#17

R4是ESP8266 Flasher Rev2的升级版,可以使用。