BlueDuino (two boards)


#1

I’m using two boards, blueduinos, that I’ve updated to 2.2.8. Updated because I was not able to connect earlier than this, but was using the smartphone BLT not BLUO. And “AT” commands work from the FTDI serial interface using Termite. I renamed the two boards LBEACON1 and LBEACON2 to see the AT command changes.

Am I supposed to be able to see the AT command response when executed from the serial monitor?

Using BLUO, I am able to connect,but get no real echoes of what I’m typing. It is set at 9600 baud on both ends. Am I missing an important setting or procedure?

thanks!
Joe.


#2

Yes. the default baud rate is 9600. did you run the sketch hardwareSerialMonitor?


#3

Yes. Arduino 1.8.5.
board #1/board #2: BN:Lilypad Arduino USB, VID: 1B4F PID: 9208

Set empty sketch.
AT command returns “OK”

AT+VERS? returns "OK+VERS:2.2.8

… AT+BCON1
… AT+ROLE0

Joe.


#4

That was from the Termite terminal session to the board.

Joe.


#5

Ah! So I had to set the Baud rate within the modem through the terminal. It wasn’t working through the sketch.

Must be require some setting at this level.

So happy days! It works!

Thanks,
Joe.


#6

good job :grin:


#7

As a follow-up for those seeking more information, I connected the BlueDuino as on the tutorial and examples.

You will need the USB to UART converter which I was lucky enough to already have. Only three wires and you’re talking to the Bluetooth module through the terminal. They leave out that once you set the firmware upload for the cc254x module, that you will need to shut down the termite terminal to run the SerialBootTool. And it will not respond unless there is an empty sketch. Load Image is performed after you select the .bin file that you want to load. It will all be obvious AFTER you are done. Plenty of room for mistakes along the way, and I did it twice, once for each board.

Joe.


#8

Thanks for your good experience!